Back to overview

Resolved DDOS attacks

Oct 31 at 05:30pm CET
Affected services
www.mizius.com (HTTPS)
www.mizius.com (HTTP)

Resolved
Oct 31 at 05:30pm CET

We've resolved the ongoing ddos attacks.